Model.AddElements doesn't manage to add/update Model from Connection (Beta) [SOLVED]

Hi all,

I’ve loaded in a model via the live Connection, then done a series of updates to elements and tried to add them back into the Model prior to saving out a copy- the problem is as soon as I try to do so grasshopper locks out when I connect the new elements into it

I also tried reading the model via a struxml filepath separately (in case there was some sort of Read-Only issue) but the Model.AddElements once again seems to crash

Lastly- I tried just saving the struxml data to it’s own model file, and then within FEM attempting the update model command, but it says Selected file is not related to current model - so I’m struggling to update

Thanks in advance!

ehy @ianshep

Do you make the changes manually in FEM-Design GUI ?

I have tried to use Model.AddElements and it seems to work correctly on my side

Hi @MarcoPelle

I tried this again and I get the same result - updating elements and setting Overwrite to True - I see your attempt is for loads - does it work for Elements too?

hI @ianshep

Model.AddElements() should work with any FEM-Design element.

Have a look at my minimal example
addelement.zip (93.5 KB)

if you can not make it working, can you share a file where you can reproduce the bug?

Hi @MarcoPelle,
Sure, I have sent over the files by email

Script work as expected. There might be some issue with VPN and License system.